Как узнать внешний ip адрес роутера mikrotik
Перейти к содержимому

Как узнать внешний ip адрес роутера mikrotik

  • автор:

Внешний ip

Author24 — интернет-сервис помощи студентам

По заданию у роутера МикроТик внутренний (192.168.10.1) и внешний айпи (172.0.0.1) где задается внешний?

Лучшие ответы ( 1 )
94731 / 64177 / 26122
Регистрация: 12.04.2006
Сообщений: 116,782
Ответы с готовыми решениями:

нет интернета на компьютере через внешний приёмник внешний wifi
На компьютере стоит RangeBooster USB Adapter внешний приёмник wifi , Windows XP.Сигнал приёма.

Что такое внешний / внешний ключ?
Что такое внешний / внешний ключ? А. Внешний / внешний ключ — это первичный ключ отношения.

Ссылка на неразрешенный внешний символ, неразрешенный внешний элемент
В программировании новичок, знакомство с подпрограммами. Помогите понять, в чем ошибка. Программа.

386 / 163 / 28
Регистрация: 24.10.2013
Сообщений: 969

Лучший ответ

Сообщение было отмечено mikrochel как решение

Решение

ЦитатаСообщение от mikrochel Посмотреть сообщение

где задается внешний?
IP—Addresses. На интерфейс который смотрит в мир.
Регистрация: 04.11.2022
Сообщений: 3

Konstantin®, получается у меня есть ether1 это от провайдера интернет, ether2 в локалку, и на ether3 задавать этот айпи?

386 / 163 / 28
Регистрация: 24.10.2013
Сообщений: 969

mikrochel, вообще внешним IP принято считать IP от провайдера, в вашем случае я не понимаю что вы понимаете под внешним IP ?
И если вы хотите повесить адрес 172.0.0.1 на eth3 вам надо будет его исключить из бриджа.

Регистрация: 04.11.2022
Сообщений: 3

Konstantin®, айпи от провайдера динамический 192.168.1.124, поднимаю роутер на виртуалбоксе, мне по заданию нужно роутеру задать внешний 172.0.0.1, что мне сделать для этого не понимаю

Эксперт по компьютерным сетям

11421 / 6991 / 1900
Регистрация: 25.12.2012
Сообщений: 29,398
Вы какой интерфейс в vb на внутреннюю сеть настраивали?

Эксперт по компьютерным сетям

4899 / 2139 / 458
Регистрация: 17.10.2015
Сообщений: 9,151

ЦитатаСообщение от mikrochel Посмотреть сообщение

что мне сделать для этого не понимаю
адрес 172.0.0.1 вешается на интерфейс, смотрящий в сторону провайдера.

ЦитатаСообщение от mikrochel Посмотреть сообщение

айпи от провайдера динамический 192.168.1.124

это откуда взято? на eth1 повешен DHCP-client и в ip-addresses на этом интерфейсе появился 192.168.1.124?
Ничто не мешает на eth1 дополнительно повесить 172.0.0.1

87844 / 49110 / 22898
Регистрация: 17.06.2006
Сообщений: 92,604
Помогаю со студенческими работами здесь

Внешний IP
Нашел на форуме способ о том как получить свой ВНЕШНИЙ IP, но, к сожалению, он не работает((.

Внешний IP
Подскажите как программно узнать внешний IPадрес компа на котором выполняется программа?

Внешний HD
Не знаю какой именно модели этот хард. Никакой наклейки, ни модели ничего, кроме марки как на.

Внешний IP
Как вывести куда нить мой внешний или глобальный IP, который например можно узнать на 2ip.ru

Внешний ip
Доброго времени суток) Написал простенькую программу(осваиваюсь), которая передает сообщение на.

Внешний ip
Здравствуйте)) Программа: Сервер-Клиент. Сервер заранее не знает клиента, только клиент сервер.

Или воспользуйтесь поиском по форуму:

Как узнать внешний ip адрес роутера mikrotik

Узнаем через сервис checkip.dyndns.org/dyndns.checkip.html

# get the current IP address from the internet (in case of double-nat)
/tool fetch mode=http address=»checkip.dyndns.org» src-path=»/» dst-path=»/dyndns.checkip.html»
:local result [/file get dyndns.checkip.html contents]
# parse the current IP result
:local resultLen [:len $result]
:local startLoc [:find $result «: » -1]
:set startLoc ($startLoc + 2)
:local endLoc [:find $result «» -1]
:global currentIP [:pick $result $startLoc $endLoc]

Результат будет записан в переменную currentIP.

Подписаться на новые статьи.

Как узнать внешний ip?

Есть ноут с убунтой 16, на нем стоит апач. Ноутбук, стационарник, подключены к wifi. В локалке ip адрес ноутбука 192.168.0.80. Хост настроен на этот же ip. Из локалки удается зайти на сайт по этому адресу. Как сделать это из вне, через интернет? Я так понимаю, нужен внешний ip. Как его узнать? Пытался гуглить, выкидывало на сайты, показывающие ip роутера. (Заходил на этот ip, поподал в конфиг своего роутера).
Я предполагаю 2 пути:
1) Использовать утилиту. Какую?
2) Рассчитать его самому, зная локальный адрес, внешний адрес роутера, и маску сети. Как именно?

  • Вопрос задан более трёх лет назад
  • 11397 просмотров

1 комментарий

Оценить 1 комментарий

alsopub

Нет у вашего ноутбука персонального внешнего IP адреса.
Внешний адрес имеет только роутер.
Далее можно использовать проброс портов на роутере.

Решения вопроса 0
Ответы на вопрос 7

Jump

АртемЪ @Jump Куратор тега Системное администрирование
Системный администратор со стажем.

Посмотреть его можно очень просто, и только в одном месте — на вашем роутере, посмотрите какой адрес присвоен интерфейсу куда подключен провайдер.
Вот это и есть ваш внешний адрес.
Но это не значит что вы сможете по нему зайти из любой точки интернета.
Чтобы заходить на ваш адрес, нужно иметь белый(реальный) адрес. Если у вас серый(частный) адрес, зайти не получится.

Пытался гуглить, выкидывало на сайты, показывающие ip роутера. (Заходил на этот ip, поподал в конфиг своего роутера).

В этом случае у вас скорее всего белый адрес, и вы можете спокойно заходить к себе на ноутбук из внешей сети, нужно просто пробросить нужные порты на роутере.
А вот тот факт что у вас админка роутера открыта наружу- это плохо.

Ответ написан более трёх лет назад
Комментировать
Нравится 1 Комментировать
Евгений Вольф @Wolfnsex Куратор тега Веб-разработка
Если не хочешь быть первым — не вставай в очередь!

1. Обратиться в поддержку провайдера и купить него внешний/»Белый IP», или получить подробности по этой теме.
2. Вывести ноутбук в DMZ (демилитаризованная зона) и/или настроить на роутере переадресацию всех входящих соединений на 80-ый порт на IP’шник ноутбука. 99% роутеров работают в режиме NAT, благодаря которому, пакеты из вне, самостоятельно не могут (в основном не могут) достигнуть получателя, если он сам не инициировал соединение. По другому это ещё может называться «проброс портов». Инстуркции можно найти в руководстве к роутеру.

P.S. Порядок действий именно такой.

P.P.S. Если IP уже белый, но динамический — можно воспользоваться сервисами типа тех, что описываются например здесь.

Ответ написан более трёх лет назад
Комментировать
Нравится Комментировать
IT, инженер

Вы на внешний IP заходили из внешней сети или из той-же?
Если из внешних сетей вас пускает по адресу до админки роутера, то вам осталось сделать только проброс портов (port forwarding) с 80 внешнего до 80 на внутренний ip (192.168.0.80).
Возможно так же придется отключить доступ к админке роутера из-вне или перевесить ее на другой порт. Это уже зависит от модели роутера и его особенностей.
Как верно написал Евгений Вольф, если внешний IP динамический, то стоит воспользоваться сервисами ddns.

Как в Mikrotik назначить IP адрес

Прежде всего, большой сегмент устройств Mikrotik — это маршрутизаторы. Домашние точки доступа к беспроводным сетям — не исключение. Маршрутизатор в общем случае стоит на границы различных сетей (например локальной — домашний сегмент и глобальной — сеть Интернет). Соответственно, без логического адреса (пары адресов) тут не обойтись.

Типовая картина следующая: для всей локальной сети выход в Интернет осуществляется через один внешний адрес (шлюз по умолчанию), а для Интернета наша локальная сеть представлена «белым» адресом, установленным на внешний (провайдерский) интерфейс. Дальше за дело берётся NAT и другие технологии, но об этом потом.

Как назначить IP адрес на Mikrotik

Способов назначения адреса может быть несколько:

  1. Ручной. Администратор самостоятельно назначает IP-адрес на реальный или виртуальный интерфейс Микротика
  2. Автоматический. За дело берётся протокол динамической настройки оконечных устройств (DHCP).

Рассмотрим оба варианта подробнее. Всю настройку я буду производить через Winbox, через web-интерфейс практически аналогично, а через командную строку настраивают те, кому эта статья особо не интересна.

Ручное назначение IP адреса

Для ручного назначения нужно перейти в раздел [IP] — [Addresses].

Далее, нажать кнопку [+] и ввести сам IP-адрес, Адрес сети (маску), а также указать интерфейс.

Подобных адресов на один интерфейс можно установить несколько.

Автоматическое назначение IP адреса

Получение настроек IP осуществляется через DHCP-клиент. Соответствующие настройки расположены в разделе «IP — DHCP Client».

Здесь добавляем новый экземпляр DHCP-клиента и указываем интерфейс, на котором он должен функционировать. Дополнительно можно отметить опции Use Peer DNS — для получения DNS-адреса, Use Peer NTP для синхронизации времени и Add Default Route — для автоматического создания маршрута по умолчанию.

Если всё сделано правильно, Микротик с указанного интерфейса будет запрашивать получение настроек IP и если в сети функционирует DHCP-сервер, то на указанный интерфейс будет автоматически назначен соответствующий адрес.

IP адрес так же может быть назначен в случае использования VPN-туннелей, LTE и т.д., но в большинстве своём там присутствует один из двух выше перечисленных способа — либо ручной, либо автоматический.

Добавить комментарий

Ваш адрес email не будет опубликован. Обязательные поля помечены *